Unable to Modify reccurring events when date has passed

Maybe this is by design, so please let me know.

If I set up a series of recurring events from say 1/1/2010 through 12/31/2010, that recur every Wednesday for a time-period, I am finding that if I go back to edit either an event, or the series, and I click on a date that is prior to today, the Save button does not always register an event. (From a user standpoint, it just does nothing.)

Originally, I thought that this was only happening when the event was passed, or when some instances have been altered individually, but as I continue to test this, I see that sometimes this is true, sometimes it is not. I know that trying to edit an event by setting the start date in the past causes this behavior every time.

So, are you aware of any instances of when the “save” button is disabled for editing recurring events? If so, wouldn’t it make sense to have some sort indication (button grayed out, or a message explaining why the event can’t be edited?) Or is this just a bug?


It sounds as a bug.
If you have any sample where it can be reconstructed - please send a link ( or sample itself , you can send it directly to the support@dhtmlx.com )

I resolved this just today by unchecking the “Prevent events overlapping” box in the admin screen. I noticed that the problem I described happened sporatically, and not based on anything that seemed specifically linked to a rule. I also had a hunch that perhaps it was some sort of div/layer issue as I have seen that before in my own development. It sounded like the “prevent overlapping” flag was to correct something like that.

I have another question though. Is there a way to add some validation to the TIME picker to set the end-time starting point to the selection of the start time?

So, if I choose “10:00 am” as the start time, the end time picker would jump to 10:00am so I can scroll down a few hours to choose my end time?


Are you using plugin version? If so which one (wordpress, joomla) and what version?

This checkbox toggles event collision logic - events could not occupy one time slot (so their start and end date could not overlap). For example you have an event from 12:00 till 14:00. Scheduler will block any attempts to create or modify existing events to happen at the same time (this includes 10:00 - 12:05, 13:55 - 18:00 and so on).

You can use following options:

To do so edit your scheduler_include.html file and add following:

<script type="text/javascript"> scheduler.config.event_duration = 30; scheduler.config.auto_end_date = true; </script>
Hope this helps.

Best regards,


I am using the WordPress plugin.

I have tried adding the javascript you suggested to the scheduler_include.html file, but it changes nothing. That file was completely blank to begin with. Should it be?



Are you using 2.3 version of the plugin? These options are available only starting with 2.3 version. If not — try updating with the latest version.

Yes, this file is blank by default. So in your case then you open lightbox timesection form ignores scheduler.config.event_duration option and doesn’t set end time according to it? Also then you change start date end date is not updated?

Best regards,