upgrading to Wordpress Scheduler v2 issues


on both my websites it upgraded the scheduler but then got the yellow loading bar but could not go to any options with the scheduler menu (under plugins)
and was getting error
expected syntax or number
settings.html line 27 char 2

so i tried click restore defaults to see what would happen then i got an error of:

Fatal error: Call to a member function children() on a non-object in
my domain/wp-content/plugins/event-calendar-scheduler/codebase/dhtmlxSchedulerConfigurator.php on line 85

tried to remove plugin and re-activate the plugin but cant due to the above error saying cannot activate due to fatal error.

Any ideas? :-S

P.s i’ve disabled all other plugins when i received the first error to rule out conflicts

If admin part of scheduler is accessible - try to enable debug mode , it will generate xml file with debug info in plugins folder.

If admin part is corrupted as well. Can you access DB and fetch values from wp_options for records WHERE option name=(“scheduler_xml”|“scheduler_xml_version”|“scheduler_php”|“scheduler_php_version”)

This for options are storing all configuration. Somehow it was corrupted in your case.

By the way, which version of WP you are using?

Plugin is updated at wordpress.org and now must work correctly.
Updated version attached to the post as well
event-calendar-scheduler.2.0.zip (484 KB)

i just installed Wordpress 2.9.2de an eventlist-scheduler 2.0.
The installation works fine, I see a calendar with one entry when i visit the event-page.

but I can’t administer scheduler via its plugins->scheduler scripts.
i receive a forever “loading” goldenyellow bar …

we use php 5.2.x on debian etch, my browser is firefox 3.6.3, but i also tried with opera.

thanks in advance


Try to clear browser’s cache, it can be caused by caching previous version of js files.

If issue still occurs , check error console of FF or Opera is it shows any messages?

hello stanislav,

thanks for your fast response.

I cleared the complete firefox chronik including the cache and restarted ff.

still not resolved, in the ff error-log are warnings related to a undefined pseudoclass first in scheduler.php.

can i somehow send you a screenshot?



You must be able to attach files to the forum posts ( “Choose” and “Add the file” buttons below the post form )

here comes the ff error-log.

might a firewall or anti-hacker-tool be the source for the problem?
or a no-script plugin?
or somehow - really don’t know how - the configuration of our apache/php server?



Those all are css level warning, which must not cause an issue.

In few days ( today, on on Monday ) , we will release an update for plugin, which will have default “show” access enabled for non-default | not-recognized user groups, which may resolve problem in your case.

thanks for your efforts

after I stopped my anti-virus program I now receive an error window as soon as I try to open the admin page.

The error listing is attached.

Any hints by that?

thanks a lot



first of all: thanks for the plugin and your support.
I installed everything on an different webserver and know it works.
Quite don’t know what JS has to do with webserver version oder configuration, but …



Server side part of scheduler requires PHP 5.x, maybe previous server has some older PHP, or some functionality of PHP was disabled.