Vault - Error uploading files (.jpg)

Hi, I took this tool again after few weeks.

My problem is that I have problems uploading some files.

I’m trying this using aspx handlers, win server 2008.

The thing is that I already upload a file but it’s not entire uploaded. When I take a look at the uploaded file it is not complete. A fraction of the files is not uploaded, it seems that it stops reading the original file. And sometimes the file stands at uploading stage and doesn’t stop, but when I see the folder, the file is there but with the same problems, it is not totally uploaded.

I tried to see what was happening but I can only tell u that the “CurrentBytesTransfered” variable get value 0 after the 2nd or 3rd iteration.

The biggest file I’m trying to upload sizes 412kb so I don’t think this is a “maxSize” problem.

I hope u could help me and I hope this issue gets solved :slight_smile:

all my greetings!!

Ok, another hint, I have downloaded the badly uploaded images and it’s size is 47.4kb, It seems to be a size restriction but I have them configured and the control should throw an error if the limit gets passed, should it?

Hello, please let me know what version of vault and aspx handler are you using, maybe send them to me.

Hi Fedor, I’m using dhtmlxVault 1.6

It is hard to help without additional information. Please send your code and description to us by email, including customer ID.

Hi Fedor, well, I’m just using the code with the vault 1.6 pack, the only code I’ve added requests a form field that includes the new path to upload the files in the uploadHandler.aspx archive.

I don’t have a customer id because we are testing your tools, so If I get this problem solved we surely adquiere the license for vault, grid and window (we are already using and testing these tools in our system)

Thx for your help :slight_smile:

Ah, I see, no problem. So the file is 412kb and what is the browser version? I will try to reproduce it on my side.

I Fedor, I’m using Google Chrome, I’ll try it in mozilla to see what happens.


I tried it in firefox and the problem happens again.

Hi, I hope someone find the solution to this, I have tried some file upload tools and those files were uploaded fine, no problems on it, but Vault is what we need. I can’t solve this.

Help please.

All my greetings!!!

Hi, has someone tried to reproduce this problem and solve it??? I haven’t been able to do this because I’m working in another projects.

Waiting for any new response.
Juan Pablo

Please send me your modified code so I can test it. My own handler has no issues, so I need your code to test.

Hi Fedor, I’m sending the fileUploadHandler.

This is what I have added to upload the file in a specific folder:

        string newPath = context.Request.Form["picsPath"].ToString() + "\\";
        string path = HttpContext.Current.Server.MapPath("~").ToString() + "\\Info\\";
        string totalPath = path + newPath;

Those lines were added to test the file uploads.

Oops, the file extension is not allowed. I have uploaded it at Rapidshare. … ndler.ashx


Hi guys,

Well I have another maybe related issue… I have posted a new thread as I think it is different, although it does use the same version of the vault (1.6) with un-modified .NET handlers (only thing changed was the location where to save the files).

The post is under my username: dsheardown (30th Sept 2010)