Very strange behaviour of Form and Grid Combo


#1

There is a very strange behaviour observed with a form and grid combo in a “2I” layout. The forms conks off when trying to insert the data. The grid’s dataProcessor isn’t allowing for the update of the fields in the grid. The fields are disabled and cannot be edited. The Headers set in the grid definition also don’t work. Form doesn’t allow any insert or update.

I have posted the complete issue in the attached pdf file.

Errors.pdf (692.3 KB)


#2

Can anyone please help fast, my job is at stake.


#3

Anyone? Please, help out. See if these console logging details help.

The errors only happen when i try to submit the form and reload the grid in the button press event. See below, the console error


It says there’s a problem in modules.php on the line# 63. I click that link and get this below highlight of the line #63 in yellow colour. It shows that myfrm.save() is illegal!!??


#4

Well, I’ve solved the issue. This can happen to anyone. Kindly close this issue as solved.