xml/java error - scheduler not working

Using wp 3.1.2 and Event Calendar / Scheduler 2.3.1, is get this

<?xml version='1.0' ?>

when trying to register a new event. After hitting enter it seems to have registered the event, but after refreshing, the event does not show.


had this problem some time ago, then it disappeared, and now its back …

Go to scheduler admin panel and turn on debug-mode please.
Then try to create new event. After that find file
and attach it here.

Please find the log in appendix. With debug mode on however, the calendar does not even show. It seems the log has not been written either, trying to access the page.
hope you can help …

just going to the scheduler admin returns this:

<?xml version='1.0' encoding='utf-8' ?>DescriptionStart dateEnd Date%

scheduler_log.txt.zip (1.08 KB)

this is what is returned with debug ‘off’ after creating an event (which disappears again afterwards):

<?xml version='1.0' ?>

Does this event goes back after you reload page or it’s gone forever?
Are you using private mode?
Could you provide link to a page with Scheduler.

It seems do be gone forever …
I dont think its private mode (everyone can make a reservation)
Here’s the link helium-group.com/aviation/re … ,mode=week

There are some problems with sending response headers when XML is requested.
Check files

They mustn’t contain any characters outside tags <?php ... ?> (especially check empty lines, please)


I have two sites running the plugin. I applied the changes you suggested. On one site it solved the problem. On The other it did not, while both the wp-config.php were changed. I even copied the plugin files from one to the other, to make sure they are the same. Also the parameters in the plugin are exactly the same, and they reside on the same server. Only difference: helium is in english, while scherma is in dutch. Strange …

working now: helium-group.com/aviation/reservations/
not working: scherma.be/agenda/

Any more suggestions?

and here’s part of the dialog box:

<?xml version='1.0' encoding='utf-8' ?></

What about server configurations?
Check if ‘output_buffering’ option has the same values in both php.ini files.

What was the solution here?